Problems with operations involving transactions

Major incident SpendControl SpendControl Mobile/Web App
2026-08-07 09:00 CEST · 45 minutes

Updates

Monitoring

The issue seems resolved, we are monitoring closely.

August 7, 2026 · 09:45 CEST
Monitoring

The app is sometimes unresponsive when trying to save or do an action on a transaction.

August 7, 2026 · 09:06 CEST

← Back